urdu Português
Inglês English Deutsch Deutsch espanhol Español Français Français italiano Italiano holandês Nederlands Português Português russo Русский Ελληνικά Ελληνικά
Login



 
Bem-vindo ao Jumi! Notícias >> Lançamentos >> Segurança

Uma vulnerabilidade de segurança foi encontrada em todas as versões Jumi 2.xx até 2.0.d (para J! 1.0), 2.0.3 e 2.1.beta2 (para J! 1.5)

Ela diz respeito componente Jumi só.

Novas versões Jumi corrigir esse problema foram liberados hoje:

  • 2.0.e estável para Joomla! 1.0
  • 2.0.4 estável para Joomla! 1.5
  • 2.1.beta3 para Joomla! 1.5 contendo outras melhorias também.

Estamos muito recomendando a atualizar para a versão Jumi novo ou fazer o seguinte manual corrigir-se.

Correção manual de vulnerabilidade de segurança

  1. encontrar os componentes do arquivo / com_jumi / jumi.php
  2. fazer em jumi.php as seguintes alterações:

Para Joomla! 1.5

mudar 11 linha

$ Fileid = JRequest :: getVar ('fileid');

to

$ Fileid = JRequest :: getInt ('fileid');

Para Joomla! 1.0

mudar 13 linha

$ Fileid = mosGetParam ($ _REQUEST, 'fileid','');

to

$ Fileid = (int) mosGetParam ($ _REQUEST, 'fileid','');

Obrigado pela sua atenção e, graças a Markus que anunciou-nos o risco.